Loading...
首页专栏正文

华为 VRRP和NQA或者是BFD进行联动,实现VRRP的快速切换

 
1人已赏
艺博东 发布于 2021-03-02 17:42:00 浏览 2914 点赞 96 收藏 8

哈喽,大家好!我是艺博东 ,一个思科出身,专注于华为的网工;好了,话不多说,我们直接进入正题。

一、VRRP+NQA

用VRRP+NQA联动实现对上行链路故障的感知以及主备网关的切换

需求:

按照拓扑配置IP地址,底层运行OSPF协议。

在R1和R2上配置VRRP备份组,其中R1的优先级为130,抢占延时为30秒,作为Master设备;R2的优先级为缺省值,作为Backup设备,实现网关的主备备份。

在R1上配置ICMP类型的NQA测试例,配置目的地址为R5上接口G0/0/1的IP地址,监测R1到R5的接口GE0/0/1间链路的连通性。

在R1上配置VRRP和NQA联动,当NQA检测到链路故障时,触发VRRP备份组进行主备切换。

二、拓扑

三、基础配置

R1

[R1]int g0/0/0
[R1-GigabitEthernet0/0/0]ip address 10.1.12.1 255.255.255.0
[R1-GigabitEthernet0/0/0]int g0/0/1
[R1-GigabitEthernet0/0/1]ip address 10.1.13.1 255.255.255.0
[R1-GigabitEthernet0/0/1]q
[R1]ospf 1 router-id 1.1.1.1
[R1-ospf-1]a 0
[R1-ospf-1-area-0.0.0.0]network 10.1.12.1 0.0.0.0
[R1-ospf-1-area-0.0.0.0]network 10.1.13.1 0.0.0.0
[R1-ospf-1-area-0.0.0.0]q
[R1-ospf-1]q
[R1]int g0/0/0
[R1-GigabitEthernet0/0/0]vrrp vrid 10 virtual-ip 10.1.12.99
[R1-GigabitEthernet0/0/0]vrrp vrid 10 priority 130
[R1-GigabitEthernet0/0/0]vrrp vrid 10 preempt-mode timer delay 30
[R1-GigabitEthernet0/0/0]q
[R1]nqa test-instance ybd 99
[R1-nqa-ybd-99]test-type icmp
[R1-nqa-ybd-99]destination-address ipv4 10.1.35.5
[R1-nqa-ybd-99]fail-percent 80
[R1-nqa-ybd-99]frequency 20
[R1-nqa-ybd-99]probe-count 5  #配置NQA测试例的一次测试探针数目为5
[R1-nqa-ybd-99]start now
[R1-nqa-ybd-99]q

R2

[R2]int g0/0/0
[R2-GigabitEthernet0/0/0]ip address 10.1.12.2 255.255.255.0
[R2-GigabitEthernet0/0/0]int g0/0/1
[R2-GigabitEthernet0/0/1]ip address 10.1.24.2 255.255.255.0
[R2-GigabitEthernet0/0/1q
[R2]ospf 1 router-id 2.2.2.2
[R2-ospf-1]a 0
[R2-ospf-1-area-0.0.0.0]network 10.1.12.2 0.0.0.0
[R2-ospf-1-area-0.0.0.0]network 10.1.24.2 0.0.0.0
[R2-ospf-1-area-0.0.0.0]q
[R2-ospf-1]q
[R2]int g0/0/0
[R2-GigabitEthernet0/0/0]vrrp vrid 10 virtual-ip 10.1.12.99

R5

[R5]int g0/0/0
[R5-GigabitEthernet0/0/0]ip address 10.1.45.5 255.255.255.0
[R5-GigabitEthernet0/0/0]int g0/0/1
[R5-GigabitEthernet0/0/1]ip address 10.1.35.5 255.255.255.0
[R5-GigabitEthernet0/0/1]int loopback 0
[R5-LoopBack0]ip address 5.5.5.5 255.255.255.255
[R5-LoopBack0]q
[R5]ospf 1 router-id 5.5.5.5
[R5-ospf-1]a 0
[R5-ospf-1-area-0.0.0.0]network 5.5.5.5 0.0.0.0
[R5-ospf-1-area-0.0.0.0]network 10.1.45.5 0.0.0.0
[R5-ospf-1-area-0.0.0.0]network 10.1.35.5 0.0.0.0
[R5-ospf-1-area-0.0.0.0]q
[R5-ospf-1]q

底层R3、R4的配置类型

LSW1

[LSW1]vlan 100
[LSW1-vlan100]q
[LSW1]int g0/0/2
[LSW1-GigabitEthernet0/0/2]port hybrid pvid vlan 100
[LSW1-GigabitEthernet0/0/2]port hybrid untagged vlan 100
[LSW1-GigabitEthernet0/0/2]int g0/0/3
[LSW1-GigabitEthernet0/0/3]port hybrid pvid vlan 100
[LSW1-GigabitEthernet0/0/3]port hybrid untagged vlan 100
[LSW1-GigabitEthernet0/0/3]q
[LSW1]int g0/0/1
[LSW1-GigabitEthernet0/0/1]port link-type access
[LSW1-GigabitEthernet0/0/1]port default vlan 100

四、测试

首先查看底层信息

[R5]display ip routing-table 已全互通

[R1]display vrrp brief R1是Master

[R2]display vrrp brief R2是Backup

现在模拟R5的G0/0/1接口故障

[R5-GigabitEthernet0/0/1]shutdown 再去R1、R2上查看VRRP信息

[R1]display vrrp R1变为了Backup

R2切换为了Master

[R5-GigabitEthernet0/0/1]undo shutdown

[R1]display vrrp brief

PC2

PC>ping 5.5.5.5 [R1]display vrrp brief VRRP协议的转态机

顺序 Initialize Backup Master

五、VRRP+BFD

5.1 需求

在作为Backup设备的R2上配置VRRP备份组监视BFD会话。一旦被监视的BFD会话的状态变为Down,VRRP备份组进行主备切换。

5.2 基础配置

R1

[R1]bfd
[R1-bfd]q
[R1]bfd 12 bind peer-ip 10.1.12.2 interface GigabitEthernet 0/0/0 source-ip 10.1.12.1 auto 
[R1-bfd-session-12]q
[R1]int g0/0/0
[R1-GigabitEthernet0/0/0]vrrp vrid 10 track bfd-session session-name 12 peer 

R2

[R2]bfd
[R2-bfd]q
[R2]bfd 12 bind peer-ip 10.1.12.1 interface GigabitEthernet 0/0/0 source-ip 10.1.12.2 auto 
[R2]int g0/0/0
[R2-GigabitEthernet0/0/0]vrrp vrid 10 track bfd-session session-name 12 peer 

5.3 测试

[R2]display bfd session all [R1]display bfd session all

[R1]display vrrp

[R2]dis vrrp

5.4 演示

模拟Master出现故障

5.5 BFD状态机

BFD会话有四种状态:Down、Init、Up和AdminDown。 (1)R1和R2各自启动BFD状态机,初始状态都是DOWN状态; (2)R2收到状态为WOMN的BFD报文之后,状态切换为INIT状态,并且发送INIT状态的BFD报文; (3)R1收到状态为WOMN的BFD报文之后,状态切换为INIT状态,并且发送INIT状态的BFD报文; (4)R2收到状态是INIT状态的BFD报文之后,本地状态切换为UP状态; (5)R1收到状态是INIT状态的BFD报文之后,本地状态切换为UP状态;

OK

一个人的胸怀能容得下多少人,才能赢得多少人。 ---- 一凡


好了这期就到这里了,如果你喜欢这篇文章的话,请点赞评论分享收藏,如果你还能点击关注,那真的是对我最大的鼓励。谢谢大家,下期见!

CSDN博客专家 微信公众号:艺博东 关注后,回复关键字“简历”,可领取简历模板

*本文仅代表作者观点,不代表易百纳技术社区立场。系作者授权易百纳技术社区发表,未经许可不得转载。

精彩评论

内容存在敏感词
打赏
打赏作者
艺博东
您的支持将鼓励我继续创作!
金额:
¥1 ¥5 ¥10 ¥50 ¥100
支付方式:
微信支付
支付宝支付
微信支付
打赏成功!

感谢您的打赏,如若您也想被打赏,可前往 发表专栏 哦~

易百纳技术社区
确定要删除此文章、专栏、评论吗?
确定
取消
易百纳技术社区