首页专栏详情
打赏
关于SS928评估板学习(四):安装操作方法
关于SS928评估板学习(四):安装操作方法
易百纳技术社区 Debug 2022-09-21 13:37:35
说明:
推荐硬件配置:
-CPU Intel(R) Xeon(R) CPU E5-2450 0 @ 2.10GHz或更好CPU
-DDR: >= 16GB
-Hard disk >= 600GB
-Gigabit Ethernet
-OS: Ubuntu 18.04.264bit
发布包使用的Linux Server版本:
Ubuntu 18.04.2 LTS (GNU/Linux 4.15.0-45-generic x86_64)

一、网络环境搭建

自行配置网络,并安装nfs,samba,ssh等网络组件。

二、软件包安装

操作系统安装好后,且配置好网络环境,则可继续如下步骤完成相关软件包的安装:
1.配置默认使用bash
执行: sudo dpkg-reconfigure das 选择no
2.安装软件包
执行:

sudo apt-get install make libc6-i386 lib32z1 lib32stdc++6 zlib1g-dev libncurses5-dev ncurses-term libncursesw5-dev g++ u-boot-tools texinfo texlive gawk libssl-dev openssl bc p7zip-full gperf bison flex diffutils git unzip

3.创建/etc/ld.so.preload文件,并执行: 

echo "" > /etc/ld.so.preload ,以解决64bit linux server上某些第三方库编译失败的问题。

4.mtd-utils依赖以下几个库,以ubuntu为例,安装命令:
 sudo apt-get install zlib1g-dev liblzo2-dev uuid-dev pkg-config automake
由于mtd-utils通过pkg-config工具检查各个库是否正常安装,因此设置pkg-config工具搜索路径:export PKG_CONFIG_PATH=”$PKG_CONFIG_PATH:/usr/lib/x86_64-linuxgnu/pkgconfig”

5.e2fsprogs依赖texlive库,安装方式如下命令:
 sudo apt-get install texlive 

6.LiteOS编译需要安装的工具包括python、pip和kconfiglib
a.确保服务器已安装python,python 2.7/3.2+均支持。如果服务器没有安装python,根据官网python 2.7安装文档或python 3.8安装文档,完成安装。

b.确保服务器已安装pip
如果pip命令不存在,可以下载源码包进行安装。pip依赖setuptools,如果setuptools不存在,也需要安装。

c.安装Kconfiglib
-对于服务器可以联网的情况。可以直接使用如下命令安装Kconfiglib:
 sudo pip install kconfiglib 

-可以采用离线的方式安装。首先在其他能联网的环境上下载Kconfiglib,当前
Kconfiglib的版本号为14.1.0,可以下载Kconfiglib的wheel文件Kconfiglib-14.1.0-py2.py3-none-any.whl或源代码文件Kconfiglib-14.1.0.tar.gz。

  • wheel文件的安装,可以参考如下命令:sudo pip install kconfiglib-14.1.0-py3-none-any.whl
  • 源代码文件的安装,可以参考如下命令:
sudo tar-zxvf Kconfiglib-14.1.0.tar.gz
cd Kconfiglib-14.1.0
sudo phyon setup.py install

7.optee模块依赖python3.x.x、pip3、wheel、pycryptodome、pyelftools库
python3.x.x安装推荐python3.7.6版本
下载安装并执行如下指令:

tar -zxvf Python-3.7.6.tgz
cd Python-3.7.6/
./configure
make
make install

wheel推荐源码安装,pip安装可能失败
下载wheel-0.36.2.tar.gz安装包

tar -xzf wheel-0.36.2.tar.gz
cd wheel-0.36.2
sudo python2 setup.py install
sudo pip3 install pycryptodome-3.9.8-cp37-cp37m-manylinux1_x86_64.whl
sudo pip3 install pyelftools-0.27-py2.py3-none-any.whl

备注:pycryptodome依赖于python3.x.x环境请先升级至python3.x.x版本再安装pycryptodome库。

三、安装交叉编译工具

1.解压工具链
执行如下命令进行解压:
 tar-xvf aarch64-mix210-linux.tgz 

2.安装工具链
运行命令:
 sudo./aarch64-mix210-linux.install 

四、安装riscv交叉编译工具

1.解压工具链
执行如下命令进行解压:
 tar-xvf cc-riscv32-cfg5-musl-xxxxxxxx-elf.tar.gz 

2.安装工具链
 cd cc-riscv32-cfg5-musl-xxxxxxxx-elf
运行命令:
 sudo./install.sh 

3.配置工具链路径
打开vi ~/.profile文件
PATH=”$HOME/bin:$HOME/cc-riscv32-cfg5-musl-xxxxxxxxelf/toolschain/bin:$PATH”
 source ~/.profile 使配置生效

五、安装SDK

1.SS928V100SDK包位置
在”SS928V100R001*/01.software/board”目录下,可以看到一个SS928V100_SDK_Vx.x.x.x.tgz的文件,该文件就是SS928V100的软件开发包。

2.解压缩SDK包
在linux服务器上(或者一台装有linux的PC上,主流的linux发行版本均可以),使用命令:
 tar -zxf SS928V100_SDK_Vx.x.x.x.tgz
解压缩该文件,可以得到一个SS928V100_SDK_Vx.x.x.x目录。

3.展开SDK包内容
返回SS928V100_SDK_Vx.x.x.x目录,运行:
 ./sdk.unpack (请用root或sudo权限执行)将会展开SDK包打包压缩存放的内容,按照提示完成操作。如果需要通过WINDOWS操作系统中转拷贝SDK包,需要先运行:
 ./sdk.cleanup 收起SDK包的内容,拷贝到新的目录后再展开。

1142
收藏
点赞
打赏
给作者打赏,鼓励他抓紧创作吧~
评论
0个
内容存在敏感词
相关专栏
打赏作者
易百纳技术社区
Debug
您的支持将鼓励我继续创作!
打赏金额:
¥1 易百纳技术社区
¥5 易百纳技术社区
¥10 易百纳技术社区
¥50 易百纳技术社区
¥100 易百纳技术社区
支付方式:
微信支付
支付宝支付
易百纳技术社区 微信支付
易百纳技术社区
打赏成功!

感谢您的打赏,如若您也想被打赏,可前往 发表专栏 哦~

审核成功

发布时间设置
发布时间:

审核失败

失败原因
备注
Loading...
易百纳技术社区
确定要删除此文章、专栏、评论吗?
确定
取消
易百纳技术社区
易百纳技术社区
在专栏模块发布专栏,可获得其他E友的打赏
易百纳技术社区
回答悬赏问答,被题主采纳后即可获得悬赏金
易百纳技术社区
在上传资料时,有价值的资料可设置为付费资源
易百纳技术社区
达到一定金额,收益即可提现~
收益也可用来充值ebc,下载资料、兑换礼品更容易
易百纳技术社区
活动规则
  • 1.周任务为周期性任务,每周周一00:00刷新,上周完成的任务不会累计到本周,本周需要从头开始任务,当前任务完成后才可以完成下一个任务
  • 2.发布的专栏与资料需要与平台的板块有相关性,禁止注水,专栏/资料任务以审核通过的篇数为准
  • 3.任务完成后,现金奖励直接打款到微信账户;EBC/收益将自动发放到个人账户,可前往“我的钱包”查看;其他奖励请联系客服兑换
  • 4.每周最后三个任务将会有以下奖品掉落:社区热卖开发板、小米音响、视频年度会员、京东卡、华为手机等等
易百纳技术社区
升级提醒
易百纳技术社区

恭喜您由入门

社区送出礼品一份

请填写您的收件地址,礼品将在3个工作日寄出

易百纳技术社区